Page MenuHomePhabricator

non-FF "Dismiss for now." isn't a label for input
Closed, ResolvedPublic

Description

When I go to a video in Safari (Mac) the message that comes has a checkbox (which I asume sets a cookie) and a <span> next to with the the text (mwe-embedplayer-do_not_warn_again) "Dismiss for now."

This should be changed into a <label> instead with the "for" attribute set to the name/id of the checkbox so that clicking the label will toggle the checkbox aswell (pointing the checkbox itself can be tricky at times..(usability)).

Krinkle


Version: unspecified
Severity: enhancement

Details

Reference
bz25661

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 21 2014, 11:15 PM
bzimport set Reference to bz25661.

I'm not sure if what's currently live on commons (loaded from prototype.wikimedia.org) is this - or that it is from the extension, but I found it over here:

http://svn.wikimedia.org/viewvc/mediawiki/branches/MwEmbedStandAlone/modules/EmbedPlayer/skins/mw.PlayerControlBuilder.js?view=markup#l758

The
779 $targetWarning.append(
780 $j('<span />')
781 .text( gM( 'mwe-embedplayer-do_not_warn_again' ) )
782 );

I guess should be changed to:
779 $targetWarning.append(
780 $j('<label />')
781 .text( gM( 'mwe-embedplayer-do_not_warn_again' ) )
782 .attr( 'for', 'ffwarn_' + embedPlayer.id )
783 );

mdale wrote:

Oky, thanks for the fix committed in r75504